外部へメールの送信ができない

事象

特定のドメイン宛てへメールの送信ができない、または届いてない。

 

原因

特定のサーバ宛てへのメールのみ送信できない・届いていないということであれば、あて先のサーバ側でメールが受け取りを拒否している可能性が考えられます。

 

/etc/mail/sendmail.mc の設定ファイルを編集し回避ができます

ssh でアクセスし root になった後、以下の行にあるコメントアウト部分 (dnl) を削除し、mydomain.com をご利用のドメインへ変更するなど必要な変更を行ってください。

変更箇所

/etc/mail/sendmail.mc 160から170行目付近

 

変更前

	dnl MASQUERADE_AS(`mydomain.com')dnl
	dnl FEATURE(masquerade_envelope)dnl
	dnl MASQUERADE_DOMAIN(localhost)dnl
	dnl MASQUERADE_DOMAIN(localhost.localdomain)dnl
	

変更後

	MASQUERADE_AS(`example.com')dnl
	FEATURE(masquerade_envelope)dnl
	MASQUERADE_DOMAIN(localhost)dnl
	MASQUERADE_DOMAIN(localhost.localdomain)dnl
	

変更が終わりましたら以下このコマンドで sendmail を再起動し、設定を反映させてください。sendmail の再起動後、テストメールをお試しください。

# service sendmail restart 

 

解消しない場合

これでも届かないようであれば、 WordPress のプラグインで外部 SMTP サーバを使用をご検討ください。

他にご質問がございましたら、リクエストを送信してください

0 コメント

ログインしてコメントを残してください。
Powered by Zendesk